Partenaire Microsoft

 

 

Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Problème ACL

Problème ACL il y a 2 ans 1 mois #2194

  • Romain LOPES
  • Hors Ligne
  • Fresh Boarder
  • Fresh Boarder
  • Messages : 10
  • Remerciements reçus 0
Bonjour,

Nous rencontrons actuellement un problème (qui est assez aléatoire) sur plusieurs établissement. Lors de la création d'un utilisateur, j'ai quelque fois des erreurs ACL

ci dessous les logs (j'ai remplacé le nom de l'utilisateur)

[ADSI] Utilisateur : "LDAP://MONDc/CN=MONUSER,OU=Mecanique,OU=Professeurs,OU=Utilisateurs,OU=KoXoAdm,DC=MONDOMAINE,DC=etab,DC=local"
[OK] Attribut personnalisé "pager=10/06/1988" pour MONUSER
[OK] [21/09/2017 14:17:10] {Ajout d'un utilisateur} Ajout MONUSER
[OK] [21/09/2017 14:17:10] {Ajout d'un utilisateur} Forcer le changement de mot de passe pour MONUSER
[OK] [21/09/2017 14:17:10] {Ajout d'un utilisateur} Ajout des groupes "CN=Mecanique,OU=Mecanique,OU=Professeurs,OU=Utilisateurs,OU=KoXoAdm,DC=MONDOMAINE,DC=etab,DC=local" à MONUSER
[OK] [21/09/2017 14:17:10] {Ajout d'un utilisateur} Ajout des groupes à MONUSER
[INFO] Création de l'espace de stockage de MONUSER
[OK] || Création du dossier "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\"
[OK] || Mise en place de l'ACL sur "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\"
[OK] || Création du dossier "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\"
[OK] || Mise en place de l'ACL sur "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\"
[OK] || Création du dossier "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\"
[ERROR] || Mise en place de l'ACL sur "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\" || Le mappage entre les noms de compte et les ID de sécurité n’a pas été effectué. (Code : 0x00000534)
[ACL] "%RID:Administrators%"->"BUILTIN\Administrateurs","%RID:LocalSystem%"->"AUTORITE NT\Système","%KOXO_ADMINS%"->"MONDOMAINE\Administrateurs de KoXo Administrator","%USER_ID%"->"???","%USER_ID%"->"???"
[OK] || Création du partage "MONUSER$"
[OK] || Création du dossier "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\CONFIG\"
[ERROR] || Mise en place de l'ACL sur "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\CONFIG\" || Le mappage entre les noms de compte et les ID de sécurité n’a pas été effectué. (Code : 0x00000534)
[ACL] "%RID:Administrators%"->"BUILTIN\Administrateurs","%RID:LocalSystem%"->"AUTORITE NT\Système","%KOXO_ADMINS%"->"MONDOMAINE\Administrateurs de KoXo Administrator","%USER_ID%"->"???","%USER_ID%"->"???"
[ERROR] || Décompression du fichier ZIP "C:\Program Files\KoXo Dev\KoXoAdm\Files\FR\web.zip" vers "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\CONFIG\" || Le mappage entre les noms de compte et les ID de sécurité n’a pas été effectué. (Code : 0x00000534)
[ERROR] || Copie du fichier texte "C:\Program Files\KoXo Dev\KoXoAdm\Files\Fr\Bienvenue Professeur.htm" vers "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\Bienvenue.htm"
[OK] || Création du dossier "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\PROFIL\"
[ERROR] || Mise en place de l'ACL sur "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\PROFIL\" || Le mappage entre les noms de compte et les ID de sécurité n’a pas été effectué. (Code : 0x00000534)
[ACL] "%RID:Administrators%"->"BUILTIN\Administrateurs","%RID:LocalSystem%"->"AUTORITE NT\Système","%KOXO_ADMINS%"->"MONDOMAINE\Administrateurs de KoXo Administrator","%USER_ID%"->"???"
[OK] || Création du dossier "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\PROFIL.V2\"
[ERROR] || Mise en place de l'ACL sur "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\PROFIL.V2\" || Le mappage entre les noms de compte et les ID de sécurité n’a pas été effectué. (Code : 0x00000534)
[ACL] "%RID:Administrators%"->"BUILTIN\Administrateurs","%RID:LocalSystem%"->"AUTORITE NT\Système","%KOXO_ADMINS%"->"MONDOMAINE\Administrateurs de KoXo Administrator","%USER_ID%"->"???"
[OK] || Création du dossier "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\PROFIL.V5\"
[ERROR] || Mise en place de l'ACL sur "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\PROFIL.V5\" || Le mappage entre les noms de compte et les ID de sécurité n’a pas été effectué. (Code : 0x00000534)
[ACL] "%RID:Administrators%"->"BUILTIN\Administrateurs","%RID:LocalSystem%"->"AUTORITE NT\Système","%KOXO_ADMINS%"->"MONDOMAINE\Administrateurs de KoXo Administrator","%USER_ID%"->"???"
[OK] || Création du dossier "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\Documents\"
[ERROR] || Mise en place de l'ACL sur "\\MONSERVER\D$\KoXoDATA\PROFESSEURS\Mecanique\MONUSER\Documents\" || Le mappage entre les noms de compte et les ID de sécurité n’a pas été effectué. (Code : 0x00000534)
[ACL] "%RID:Administrators%"->"BUILTIN\Administrateurs","%RID:LocalSystem%"->"AUTORITE NT\Système","%KOXO_ADMINS%"->"MONDOMAINE\Administrateurs de KoXo Administrator","%USER_ID%"->"???","%USER_ID%"->"???"
[OK] || Création du fichier "Desktop.ini"


Je précise que nous avons 2 contrôleurs de domaine et un serveur de fichiers. KoXo est installé sur un des deux DC.
Je pense que lors de la création de l'utilisateur ou du groupe, les étapes s’enchaînent "trop vite" et le nom de l'utilisateur ne peut donc pas être résolu.

Avez vous une solution a ce problème ?

Merci

Connexion ou Créer un compte pour participer à la conversation.

Problème ACL il y a 2 ans 1 mois #2195

  • Admin KoXo
  • Hors Ligne
  • Administrateur
  • Administrateur
  • Messages : 1311
  • Karma: 22
  • Remerciements reçus 182
Bonjour,
L'erreur de mappage veut dire que le serveur n'arrive pas à construire la liste d'ACE, entre autre il n'arrive pas à résoudre le nom de l'utilisateur "%USER_ID%"->"???".
Vous devez avoir des problème de réplication d'AD ? de DNS ?
Pour être efficace KoXo Administrator doit être installé sur le serveur de fichier et s'il est DC aussi c'est encore mieux.
Dans la fiche de configuration, au niveau de l'onglet "serveurs" vous mettez en premier votre serveur de fichier (qui est aussi dc). L'autre serveur n'a sans doute pas besoin de s'y trouver sauf s'il y a aussi des lieux de stockage dessus.
Cdt
Le support

Connexion ou Créer un compte pour participer à la conversation.

Problème ACL il y a 2 ans 1 mois #2196

  • Romain LOPES
  • Hors Ligne
  • Fresh Boarder
  • Fresh Boarder
  • Messages : 10
  • Remerciements reçus 0
Bonjour,

pas de problème de réplication AD, tout se fait correctement (le domaine est déployé juste avant l'installation de KoXo).
Nous sommes obligé d'avoir les deux serveurs car les rôles serveur de fichiers et contrôleur de domaine sont séparés.

Que pensez vous de mon hypothèse concernant la latence ?
Est il possible de positionner une latence entre la création du compte et la mise en place des ACLs ?

Connexion ou Créer un compte pour participer à la conversation.

Problème ACL il y a 2 ans 1 mois #2197

  • Admin KoXo
  • Hors Ligne
  • Administrateur
  • Administrateur
  • Messages : 1311
  • Karma: 22
  • Remerciements reçus 182
Bonjour,
KoXo Administrator crée un compte sur votre DC à distance et essaye en suite de résoudre le SID sur le serveur de fichier, sauf qu'il n'y arrive pas.
Normalement ce scénario fonctionne.
S'il y a des lenteurs entre les DC, il faut dire de créer les comptes sur le FS qui est aussi DC.
Le DC se synchronisera quand il le pourra.
Si vous demandez de réparer le compte utilisateur ultérieurement, avez vous des erreurs ?
Cdt
Le support

Connexion ou Créer un compte pour participer à la conversation.

Dernière édition: par Admin KoXo.

Problème ACL il y a 2 ans 1 mois #2201

  • Romain LOPES
  • Hors Ligne
  • Fresh Boarder
  • Fresh Boarder
  • Messages : 10
  • Remerciements reçus 0
Bonjour,

Dans notre cas le FS n'est pas DC, les rôles sont complètements éclatés sur trois serveurs (2 DC + 1 FS)

Lors de la réparation aucun problème tout fonctionne correctement.
Est ce que l'on peut cibler un DC en particulier lors de la création d'un compte depuis KoXo ? De même lors de la mise en place des ACL ?
Cela résoudrait le problème

Connexion ou Créer un compte pour participer à la conversation.

Problème ACL il y a 2 ans 1 mois #2202

  • Admin KoXo
  • Hors Ligne
  • Administrateur
  • Administrateur
  • Messages : 1311
  • Karma: 22
  • Remerciements reçus 182
Bonjour,
En principe on indique un DC en premier. Ce DC peut aussi être le FS.
Dans votre cas il y a des problèmes de lenteurs extrêmes visiblement.
La plupart des utilisateurs de la solution ont un FS et DC séparés et ça ne pose pas de problème.
Quand KoXo Administrator crée des utilisateurs sur le DC il crée des stockage et résous les SID...et attend un peu si nécessaire...dans votre cas il faudrait attendre très longtemps et du coup la création de compte serait très lente. En principe un utilisateur neuf est créé en 1 à 2 secondes selon les performances du système.
Cdt
Le support

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.405 secondes